Thinking in Three Dimensions: An Exploration of Analytical Methods for Optical Sections from Confocal Microscopy Using ImageJ

Michael J. Keller

College of Chemical & Life Sciences, 1222 H.J. Patterson Hall (Bldg. 073), University of Maryland, College Park MD 20742 USA
(kellermi@umd.edu)

The microscope has long been a key piece of laboratory equipment, and in modern research fluorescence microscopy has become the dominant technology. Confocal microscopy has gained prominence through image clarity and the ability to generate three dimensional image data through optical sectioning. This exercise uses the open-source software package ImageJ to explore the analysis and representation of fluorescent images in two- and three-dimensions using confocal image stacks. Manipulations by students include merging color stacks, making a two-dimensional image montage, generating a two-dimensional z-projection of a three-dimensional stack, and rotating stacks in three dimensions.

Keywords: ImageJ, confocal microscopy, image analysis

Introduction

In the life sciences a great deal of time is spent observing organisms at multiple levels, from the behavior of the individual down to high resolution structural analysis of individual cells. Unfortunately our methods of observation and analysis often require removal of smaller objects from a larger whole, necessitating the subsequent extrapolation to and reconstruction of the original context. In microscopy this reductionism has taken the form of sectioning: the slicing of thick tissues into very thin sheets that light can pass through with minimal distortion. Sections of tissues provide a wealth of information about cell structure at high resolution in two dimensions at the cost of nearly all information about the three dimensional structure of the original tissue. Reconstructions of three dimensional objects are traditionally difficult and time-consuming, and have become practical only recently with the development of digital imaging and automated post-processing technology. Optical sectioning on the other hand allows direct observation and imaging of three dimensional structures in vivo.

Confocal microscopes are prohibitively expensive for the majority of teaching laboratories, so students are not afforded the opportunity to experience this technology despite its dominance in life science research. However, using freely available software and data contributed from researchers, students can gain hands-on experience manipulating and analyzing confocal image data in three dimensions. The exercises presented here were designed to supplement a traditional microscopy lab that emphasizes the limitations of using 2D sections to draw conclusions about 3D objects. This example uses two-color image stacks of neurons in the developing zebrafish hindbrain to examine the task of counting cells in three dimensions.

ImageJ is a platform independent Java application for image processing developed by Wayne Rasband at the NIMH in Bethesda, MD. The core program utilizes a library of hundreds of plug-ins developed by the larger scientific community to accomplish a variety of image processing and automation tasks. Standard plug-ins allow ImageJ to open “stacks” of images (“slices”) in Bio-Rad or Zeiss LSM formats and read the accompanying metadata, which can then be manipulated using built in image stack processing functions.
**Student Outline**

**Background - Tools for Visualizing Biological Specimens in 3D**

In the previous exercise you learned the importance of thinking about the two dimensional representations of data typical of cell biology in three dimensions. Traditional optical imaging methods such as light or electron microscopy use two dimensional slices, or sections, of biological specimens to obtain high resolution data. A series of sections must be imaged and used to construct a three dimensional view of the original object. Until the relatively recent development for computer applications to assist in reconstruction, microscopists would depend on painstaking comparisons among sections or cut-paper models of sections for analysis.

The process of physically sectioning a specimen has benefits, chiefly the ability to obtain high-resolution color images using a simple light microscope. However, sectioning has a number of drawbacks that make it less than ideal, such as the inability to precisely control the position and orientation of sections within a specimen, or the difficulty of precisely matching serial sections of complicated objects. And, obviously, physical sectioning precludes the study of live samples.

In modern cell biology laboratories, physical sectioning has been largely replaced by optical sectioning using a technique called Laser Scanning Fluorescence Confocal Microscopy, or confocal microscopy for short. Dyes and antibodies labeled with fluorescent molecules are used to “stain” structures in whole tissues different colors. Lasers are used to “scan” a two dimensional layer with the tissue, and multiple layers are scanned to form a “stack” of images. Different wavelength lasers can scan different colors, so it is possible to image up to three or four structures at the same time. Confocal microscopy can even be used to image live cells or organisms that express recombinant genes tagged with fluorescent proteins. There are various methods for manipulating, analyzing, and presenting three-dimensional data using a variety of computer applications. In this exercise you will manipulate three-dimensional representations of cellular and molecular data using ImageJ.

**Procedure: Manipulating Image Stacks**

You will use the application ImageJ, developed by our friends at NCBI, to manipulate stacks of images collected with a confocal microscope. The images in the stacks are of a part of the developing zebrafish embryonic brain, with nuclei stained blue by a dye (DAPI) and actively dividing cells marked by antibodies labeled with a green dye. The data have been stored as two separate stacks, one for blue and one for green.

These data were collected as part of a project to determine if loss of function in a gene known to influence brain development altered the proportion of dividing cells in the brain. In order to answer this question, it is first necessary to determine the best way to analyze the images. As you learned in the previous exercise, it is difficult to accurately count cells or structures in individual sections.

*Are the data best viewed as separate stacks, or are you better off combining them?*

*What is the best way to display the data in the stacks to visualize and count dividing cells?*

1. In the applications bar, click on the icon for ImageJ (an old-fashioned microscope). You will see a set of menus and a tools pallet for ImageJ.
2. Open the image stacks, located on the desktop in files named “Stack_Blue” and “Stack_Green,” using the Open command in the File menu.
3. Information about each image stack is displayed at the top of each window.

   *How many “slices” are in each stack?*
   *How big is each image in each stack?*

4. Use the scroll bar at the bottom of each window to “move” up and down through the image stack.

   *How difficult is it to tell which cells are the same in different images within a stack?*
   *How difficult is it to tell which cells are the same between the two stacks?*

5. Try merging the two stacks into a single two-color image stack. Under the Image menu, go to Color and select Merge RGB... Make sure to select the appropriate stack for “Green” and “Blue” and set “Red” to none. Check the box for “Keep source images,” and then click the OK button.
6. Scroll through the merged two-color stack. 

*Is it easier to tell which cells are same in different images of the stack, is it still difficult?* 
*Is it easier to tell which cells are same in blue and green?*

Next we wish to compare three ways of summarizing and presenting the three dimensional data from stacks of two dimensional images two get a better overview of the original structure.

7. First, with the two-color stack selected (“RGB”), under the Image menu go to Stacks and select *Make montage*.... You can use the default settings, so just click the OK button. A “photo montage” showing all the layers of the stack at once will be displayed. This format has the advantage of displaying all of the original data as it appears without the need to scroll through the stacks, however there is a lot to look at. Move the “Montage” window to the right side of the screen.

8. Next, again with the “RGB” window selected, under the Image menu got to Stacks and select *Z Project*.... In the options window, set the drop-down menu to “Max Intensity” and click the OK button. A new window titled “ZProjection of RGB” will display a “flattened” image of the stack.

This has the advantage of simplifying the data to a single image, but removes all information about depth. Move the “ZProjection of RGB” window to the right side of the screen as well.

9. Finally, again with the “RGB” window selected, under the Image menu go to Stacks and select *3D Project*.... For best results, make sure the values in the options window are set as follows:

![3D Projection](image)

A new window labeled “Projection of RGB” will be displayed, containing a series of three dimensional views of the two-color stack viewed at different angles or “rotations” about the horizontal (x) axis. Use the scroll bar to rotate the three dimensional reconstruction of the original zebrafish embryonic brain tissue.

*Which projection method do you think best represents the data from the original image stacks? Why?* 
*Which projection method would you choose to count the number of dividing cells? Count the number of green cells in the Z Projection and the 3D Projection, do you get the same result?*

10. Show your three projections to your TA before you close the windows to receive three bonus points!
**Mini Workshop: Analyzing 3D Data with ImageJ**

Notes for the Instructor

ImageJ is open-source and freely available at http://rsbweb.nih.gov/ij/ as are many useful plug-ins. Confocal image stacks can be requested from researchers at your own or other institutions, or through a stack archive under development at www.terpconnect.umd.edu/~kellermi/Stacks.html.

First, students were asked to examine a thin section of *Amphiuma* liver using a bright-field microscope and consider the best way to count individual cells, and if that task could be accomplished from a single section with any accuracy. This leads to discussions of the importance of three-dimensional morphology and section orientation on interpretations of cells in sections. After an introduction to the principles of confocal microscopy (Figure 1), students are led through a series of image processing tasks using ImageJ and asked to consider the pros and cons of different data presentation schemes for the task of counting cells.

A typical example of an image stack students might work with is the embryonic zebrafish hindbrain at 24 hours post-fertilization (hpf) with all nuclei stained blue with DAPI and mitotic nuclei marked by phospho-histone H3 antibody with a green fluorescent secondary. Students are assigned the “simple” task of counting the number of mitotic nuclei, and are led through a series of tasks that let them look at the same data in different ways. They are encouraged to discuss the advantages and disadvantages of each approach, consider their perceived level of confidence in obtaining the correct cell count using each approach, and compare actual cell counts for consistency.

**Task #1: Merging RGB Stacks**

The first thing students do is open a two-channel LSM image stack (or two one-channel TIFF stacks) and learn to scroll through the layers of images along the Z-axis and make observations about the data (Fig. 2A, B). One important observation they make is that some cells appear in more than one slice. They may also observe that the blue nuclei appear smaller than the green nuclei. Both these issues are artifacts of laser confocal scanning that depend on pinhole size and wavelength of light, as well as the detector. For example, brighter objects look bigger than dimmer objects in all three dimensions. The initial image processing task is to merge the two channel data into a single multi-color stack (Fig. 2C).

**Figure 1.** All confocal microscopes are based on basic property of the compound microscope: the light paths from any point in the focal plane pass through the objective and converge at a second point in the image plane of the objective. The image plane is what the oculars of the microscope project onto the eye. These two points, one in the focal plane of the object, and the other some distance behind the objective, are conjugate foci of the objective, or confocal points. In the laser-scanning confocal microscope, a beam of monochromatic laser light passes through a dichroic mirror and induces fluorescence in a discrete volume of a sample. The light emitted by the sample back through the objective is reflected towards a detector by the dichroic mirror. A plate with an adjustable diameter pinhole is placed in the light path before the detector in the image plane of the objective, so that a point in the focal plane of the sample and the pinhole are confocal. Light emitted from the focal plane will pass through the pinhole (path a), whereas out-of-focus light emitted from outside the focal plane with be blocked (path b).

**Task #2: Displaying 3D Stacks as 2D Montages**

One way to look at 3D image stacks is to treat them the same as traditional physical sections and present the data as a montage of images (Fig. 3). This approach is useful when presenting images with overlapping opaque elements, but sacrifices the initial advantage of collecting 3D data. Here, students typically comment on the difficulty of judging which cells are the same or different on different slices in the montage.

**With the merged stack open, select “Image>Stacks> Make Montage”**

---

Mini Workshop: Analyzing 3D Data with ImageJ
**Figure 2.** An example of one “slice” taken from the same level in different stacks (A) blue channel, (B) green channel and (C) merged image stack.

**Figure 3.** A “montage” of the twelve slices in the merged image stack.
Task #3: Displaying 3D Stacks as 2D Projections

Next, students generate “flattened” stacks that reduce all of the image data down to 2 dimensions (Fig. 4). This provides an easy to view, printable “summary” of all the data, and can be very useful in the absence of spatial complexity, providing the visual advantages of a traditional section without loss of information about the third dimension. However, it is usually readily apparent that it makes it impossible to see if there are overlapping cells and student confidence about cell counts is not much higher than with the montages.

<table>
<thead>
<tr>
<th>With the merged stack open, select “Image&gt;Stacks&gt; Z-project”</th>
</tr>
</thead>
<tbody>
<tr>
<td>• For most applications choose “Max Intensity”</td>
</tr>
</tbody>
</table>

Z-projections can also be from single-channel stacks for comparison

Task #4: Displaying 3D Stacks as 3D Projections

The most useful application of 3D fluorescent image stacks is the generation of rotations or 3D projections (Figure 5). These are dynamic image series that must be viewed on the computer, however, so they are not as familiar as the preceding methods or as practical for publication. Students can try rotating stacks about different axes, try different interpolation parameters, and choose finer or courser rotation series. In the end they should determine the best way to generate a 3D projection of their data to accomplish the task of counting cells with confidence.

<table>
<thead>
<tr>
<th>Select “Image&gt;Stacks&gt;3D Project” from the menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>• Use “Brightest Point”</td>
</tr>
<tr>
<td>• “Slice spacing” will depend on voxel size; start with 8-10 and select a scale that gives the best looking (roundish) nuclei</td>
</tr>
</tbody>
</table>

**Figure 4.** A “flattened” representation of the RGB merged image stack obtained using the Stacks>Z Project function in ImageJ, with the Max Intensity option.

**Figure 5.** A montage of rotations of the RGB merged image stack at 30° intervals about the X-axis.
Acknowledgements

This exercise was developed as part of the BSCI105, Principles of Biology I Laboratory offered by the Biological Sciences Program in the College of Chemical & Life Sciences at the University of Maryland.

About the Author

Michael Keller earned a B.S. from the State University of New York at New Paltz, an M.S. from Villanova University, and a Ph.D. from the University of Missouri, Columbia. He was a post-doctoral fellow at the National Institute of Child Health and Human Development before accepting his current position as Lecturer and Lab Coordinator at the University of Maryland.

Mission, Review Process & Disclaimer

The Association for Biology Laboratory Education (ABLE) was founded in 1979 to promote information exchange among university and college educators actively concerned with teaching biology in a laboratory setting. The focus of ABLE is to improve the undergraduate biology laboratory experience by promoting the development and dissemination of interesting, innovative, and reliable laboratory exercises. For more information about ABLE, please visit http://www.ableweb.org/

Papers published in Tested Studies for Laboratory Teaching: Proceedings of the Conference of the Association for Biology Laboratory Education are evaluated and selected by a committee prior to presentation at the conference, peer-reviewed by participants at the conference, and edited by members of the ABLE Editorial Board.

Although the laboratory exercises in this proceedings volume have been tested and due consideration has been given to safety, individuals performing these exercises must assume all responsibilities for risk. ABLE disclaims any liability with regards to safety in connection with the use of the exercises in this volume.

Citing This Article


Compilation © 2011 by the Association for Biology Laboratory Education, ISBN 1-890444-14-6. All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form or by any means, electronic, mechanical, photocopying, recording, or otherwise, without the prior written permission of the copyright owner. Use solely at one’s own institution with no intent for profit is excluded from the preceding copyright restriction, unless otherwise noted on the copyright notice of the individual chapter in this volume. Proper credit to this publication must be included in your laboratory outline for each use; a sample citation is given above. Upon obtaining permission or with the “sole use at one’s own institution” exclusion, ABLE strongly encourages individuals to use the exercises in this proceedings volume in their teaching program.